Home News Buyers Guide About Advertising
Page 1 of 3 123 LastLast
Results 1 to 10 of 37

Hybrid View

  1. #1
    Join Date
    May 2005

    Question CameraWindow problem?

    Hi everyone.

    I've just got my first digital camera, the A520, wanted something relatively inexpensive and functional and am very pleased with it so far. Have helped other people with their cameras and am reasonably computer literate but have been having problems connecting the camera to my PC (am using XP Home).

    I had some other (Nikon) digital camera software installed, which I completely removed before installing the provided Canon software.

    I did the standard installation, restarted, followed instructions to the letter, and after plugging camera in and switching on (in 'play' mode), waited.

    The CameraWindow event dialog doesn't automatically open, but the CameraWindow launcher appears in the taskbar as though it's trying to.

    If you go >Programs >Canon Utilities >CameraWindow or open ZoomBrowser EX and try 'acquire', it says 'CameraWindow already running. Start aborted' - as though CW is open already, it's just not visible on my screen!

    Clicking (left, right or double) on the taskbar icon doesn't do anything either, nothing opens, no menu or window, zip!

    In 'My Computer', the camera is recognised as 'Canon Powershot A520', asking for camera properties gives 'The imaging device is busy, or may be in use by another application. You may cancel or continue to wait for the device to become available'.

    The Microsoft Scanner/Camera wizard when launched tries to communicate and says 'The scanner or camera is in use. Please try again later'. By this point, the 'launcher' icon has vanished, but if you try to open CameraWindow manually, reappears and again, nothing else seems to happen!

    Can anyone offer any suggestions?

    I haven't got a cardreader at the moment, but if I pop the SD card into my PDA I can download my pics via that with no problem (just a bit slower), but I'm a bit mystified. I have uninstalled everything and tried again, and I've restarted half a dozen times but no luck.

    Any suggestions gratefully received!


  2. #2
    Join Date
    Jun 2005
    I have had this EXACT same problem with my new SD300. Help would be very much appreciated!

  3. #3
    Join Date
    May 2005

    Lightbulb No luck so far..

    Well, I contacted the Canon helpdesk and explained the problem, and they replied with:

    'After connecting the camera and letting Zoombrowser open, or opening it manually, press the blue Direct Transfer button on the camera. This will override any problems with the Camera Window program, and should start the download.'

    Tried that, didn't work - nothing happens when I press this button - so contacted them again, saying this, and their next suggestions were:

    'Please ensure that you connect the device directly to a USB port and not via an external hub or adaptor.

    You could also uninstall and reinstall the software to rule out a software issue.

    If the problem persists you could install and test it on a second PC to rule out a hardware fault.'

    I'd tried all of those, all of my USB ports are direct but changing port didn't make a difference either. I haven't had a chance to try it on a second PC, but will do when I get access to another. In the meantime I'm doing the slightly ridiculous routine of putting the SD card into my PDA and downloading the pictures onto my PC from the card via the PDA!

  4. #4
    Join Date
    Jun 2005
    I should add that the CameraWindow occasionally pops up, but when it does, it is always empty - it displays no options for programs to launch.

  5. #5
    Join Date
    May 2005


    Yep, same here. Irritating, isn't it? I've deleted any other photo-imaging/camera software on my computer too.

  6. #6
    Join Date
    Jun 2005
    I tried plugging my camera into another PC, and it worked. The CameraWindow popped up, with a number of programs to select from. I chose one and the photos loaded successfully. Does this mean that the problem is with my computer, or my software, or my USB port, or what? I've also plugged in my brother's Nikon to my computer and the CameraWindow has successfully appeared with a number of options.

    I've tried uninstalling and reinstalling the software a number of times. When I try to run Camera Wizard, it says the camera is in use.

    Would my results be any different with a card reader?

  7. #7
    cateyed Guest

    Smile Disabled service

    Hi all,

    I was experiancing the same problem with my Ixus 750. My problem ended up being that my "Canon Camera Access Library 8" service was unable to start, due to one of the dependancies not being started.

    I discovered that my "SSDP Discovery Service" was disabled, and hence was stopping the Canon service.

    I changed the SSDP Discovery Service to Manual, and restarted the Canon Camera service, and all was well. CameraWindow started straight away.

    You might also check the "Windows Image Acquistion" service, as this is also a dependancy for the Canon Camera service.

    Hope this helps someone!


  8. #8
    Eric Hill Guest

    Thumbs up CameraWindow problem? - Solved

    Quote Originally Posted by cateyed
    my "SSDP Discovery Service" was disabled, and hence was stopping the Canon service.


    Hope this helps someone!

    This was very helpful!

    Thank you!!


  9. #9
    LouisHirst Guest

    Exclamation SSDP Discovery Service / Canon CameraWindow

    Folks the SSDP Discovery Service is bad because it opens up a vulnerability in windows. I'm not here to make you scared or paranoid, it's just a fact that UPNP could be used by a hacker to exploit your computer. Simply put, UPNP allows someone to establish a connection to your computer without you knowing - which is never good. The root of this problem is that the canon camera access library 8 service wants to depend on it, so you can't run one without the other.

    However! - We can modify the canon access library service to no longer depend on the SSDP service – which it doesn’t need in the first place!

    1 - open regedit
    2 - goto HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\C CALib8
    3 - double click on DependOnService
    4 - delete the second line "SSDPSRV"
    5 - close regedit
    6 – open up services (start->run>services.msc)
    7 – stop the SSDP Discovery Service
    8 – done

    Congratulations, you have won a battle against the hackers and made the net slightly safer.

    p.s. as I understand it UPNP was created by people who wanted firewalls to open up incoming ports automatically for things like NAT traversal. Unfortunately, as we know, the bad people will always use things like this to bolster their bot fleets. Good luck.

  10. #10
    Join Date
    Mar 2006
    I went into my registry and i dont even have C CALib8 in there.

    am i safe? mine works but if i uninstall the canon software i can still just transfer files from the camera with a card reader or when it shows up in my computer as a removable drive.

    I just use the canon software because it sorts the images into dated folders.
    My camera gear Found on e-bay.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts