I found this on another site. I did not check out all the links. Take it for what it is worth.


I was thinking hard and long before posting this as I don't want to kill any enthusiasm that has developped on this forum re the A77.
Apparently the current batch of A77s has/can/might develop some issues that have to be solved by Sony. So if I were in your position I might want to hold back with running out and ordering one as you might end up having to return it or wait for a bug fix.

Now please take note I said "might"! The strange thing is that these bugs did NOT happen when reviewers reviewed the A77!

Here are some links that are off some concern:


It sounds like Sony will have two cameras to fix, the Sony NEX-5n and now the Sony A77 too!


...suddenly the camera stopped working properly...


Many people from Taiwan and Hong Kong, has reported that the Firmware V1.02 contains lots of Bugs.



Hong Kong:



1, All the AF point disappear suddenly, and could not switch off the camera and could not change some of the setting within the menu.
Image control:Zoom outZoom 100%Zoom inExpand AllOpen in new window

2,The camera hang suddenly and you have to remove battery and restart the camera.

3,A few people has put a Sigma lens on the camera and all the focus point loss forever.
No more AF for any lens(include Sony's), and need to return to CS to fix it.

4,It needs more than 10sec to turn off the camera.
Sometimes you turned off the camera, but it is still working,
the battery drop from 9x% -> 9% after a few hours.

5, The orientation of the menu does not show correctly.

6,The Aperture & Shutter setting malfunction suddenly, need to remove battery and restart the camera.

7,The position of the electronic level shift to the top part of the LCD. Need to restart the camera to back to normal position.

8,The camera hang during shooting in high speed mode .

-> faulty A77


Well what happened is I was playing with my new toy when suddenly it stopped working, then I switched it on and since then I'm able to see only black screen or go to the menu, where I can't change anything. Tried everything, taking off battery, connecting to pc ( couldn't do even that)

And there are many more

So far nobody seems to be sure whether this is a hardware problem or a firmware issue!

Please I really do not want to kill your enthusiasm and as said, some people do NOT have these problems, but you might want to check!