Home News Buyers Guide About Advertising
 
 
 
   
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: SB-600 problem

  1. #1
    Join Date
    Aug 2005
    Posts
    6,931

    SB-600 problem

    I know that this is going to be a duh! moment and that I will probably feel stupid soon but here goes.

    My SB-600 will not go into BL mode. I can cycle through M and TTL modes but BL seems to have completely disappeared.
    This happens with the flash both on and off the camera. I have tried the two button reset and also removing the batteries.
    All other flash functions seem to work okay (zoom, M power adjust, etc).
    What stupid thing have I done?

  2. #2
    Join Date
    Dec 2006
    Location
    Melbourne, Australia
    Posts
    793
    When I've played around with it I think BL only comes on with the flash on the camera and the camera turned on. It seems to disappear with the camera turned off. It has been a while since I've used BL so I might be wrong.
    Nikon D700 | SB600 | SB-80DX | 2xSB-26 | 18-35 f/3.5-4.5 | 24-85 f/3.5-4.5G | 50 f/1.4 G | 105 f/2.8 VR | 70-300 f/4.5-5.6 VR

    flickr

  3. #3
    Join Date
    Dec 2006
    Location
    God's Country - Australia
    Posts
    10,424
    sb600's dont work in BL mode with a d50. you will have to upgrade to a d90 or d300.
    D800e l V3 l AW1 l 16-35 l 35 l 50 l 85 l 105 l EM1 l 7.5 l 12-40 l 14 l 17 l 25 l 45 l 60 l 75
    flickr

  4. #4
    Join Date
    Aug 2007
    Location
    Adelaide, Australia
    Posts
    554
    hahahaha ROFL nice one rooz, right where it hurts!
    Nikon D7000 - Nikkor AF-S 70-200vrII f2.8 | Nikkor AF-S 105vr f2.8 Micro | Nikkor AF-S 16-85 | Nikkor AF-D 35mm f2 |Tamron SP 90mm f/2.8 Di Macro | SB-700 | SB-600


    Website

  5. #5
    Join Date
    Aug 2005
    Posts
    6,931
    Quote Originally Posted by Rooz View Post
    sb600's dont work in BL mode with a d50. you will have to upgrade to a d90 or d300.

    I hear that there is a cheap D300 with dodgy colour rendition available in Sydney. Would you have the contact details fro the sucker who purchased by any chance because maybe I can get it cheap enough to make it worthwhile as long as I don't photograph orange things.

  6. #6
    Join Date
    Mar 2007
    Posts
    2,132
    BL worked on my D80, but I didn't use it.

    It was only in certain conditions though - tried A/S/M modes? Change some things around...I can't remember what it would be.
    Nikon D300 | Tamron 17-50mm f/2.8 | Nikkor AF-S 70-300mm VR | Nikkor AF 35mm f/2 D | SB-600 | Lowepro Voyager C | Lowepro Slingshot 300 AW

    For Sale:
    Nikkor AF 35mm f/2 D - Like New (FX compatible)

    Wish List
    Nikkor AF-S 17-55 f/2.8
    Nikkor AF-S 70-200 f/4 VRII
    Tokina AF 11-16 f/2.8
    SB-900 (2)
    Umbrellas
    New Tripod

  7. #7
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Posts
    4,428
    SB800 BL doesn't work on some settings or modes on D80. I think it's the different metering - BL doesn't work on spot metering I think?? I can't be sure since I'm nowhere near the camera to test it right now. Maybe it's the same on your camera.
    Nikon D90, D80
    Nikkor 16-85mm AF-S DX F/3.5-5.6G ED VR, Tamron SP AF 28-75mm F/2.8 XR Di LD Aspherical (IF) macro, Nikkor 50mm F/1.4D, Nikkor 50mm F/1.8D, Nikkor AF-S VR 70-300mm F/4.5-5.6G IF-ED, Sigma 105mm F/2.8 EX DG Macro ||| 2x SB800 | SB600 ||| Manfrotto 190XB

  8. #8
    Join Date
    Aug 2005
    Posts
    6,931
    I have a sneaking suspicion that it doesn't work when the camera is in spot metering mode and I have another suspicion that that may be the mode my camera is currently in.
    As I said I expect this to be a duh! moment.

  9. #9
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Posts
    4,428
    Ahhhhh........ it's the spot metering then. Well, I panicked out of my wit when that duh moment happened to me.
    Nikon D90, D80
    Nikkor 16-85mm AF-S DX F/3.5-5.6G ED VR, Tamron SP AF 28-75mm F/2.8 XR Di LD Aspherical (IF) macro, Nikkor 50mm F/1.4D, Nikkor 50mm F/1.8D, Nikkor AF-S VR 70-300mm F/4.5-5.6G IF-ED, Sigma 105mm F/2.8 EX DG Macro ||| 2x SB800 | SB600 ||| Manfrotto 190XB

  10. #10
    Join Date
    Sep 2007
    Posts
    326
    Tim

    you are correct. I just tested my SB600. TTL-BL is not available on spot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •