Home News Buyers Guide About Advertising
Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2008

    EOS Utility problem

    EOS utility will not recognize my new EOS XSi. Even after downloading the latest version from the Canon website, it still will not see the camera, though Windows Photo gallery has no problem with it. Canon support suggested unplugging any printers and scanners (of which i had none) which my conflict with it and restarting WIA. This still did not solve the problem.

  2. #2
    Join Date
    Sep 2007
    Did you uninstall-reinstall? My XSi gets a little flaky from time to time also
    | Canon 7D| Canon 5D|Canon EF 70-200mm f/4L IS USM | Canon EF-S 17-55mm f/2.8 IS| Canon EF 50mm f/1.4 | Canon EF 85mm f/1.2L II |
    my photos on flickr

  3. #3
    Join Date
    Jun 2006
    Sydney, Australia
    i don't know if it's the same problem, but when i first got my 40d up and running on my computer, EOS utility would not happen
    it didn't even install off the cd
    so i had to manually open and explore the cd, and i created a shortcut to the .exe file and manually install it like that (or something)
    now i click on the shortcut, eos utility opens, plug the camera in and turn it on, and it works like normal

    not sure if that helped any, but it's there if you need it
    Canon Powershot S3 IS
    Canon EOS 40D + Battery Grip BG-E2N | EF 24-70mm f/2.8 L USM | EF-S 10-22mm f/3.5-4.5 USM | EF 85mm f/1.8 USM | EF 100mm f/2.8 Macro USM | EF 70-200mm f/2.8 L IS USM II | 580EX II |
    Flickr - blentley

  4. #4
    Join Date
    Jun 2008
    I've re-installed the software twice and still no luck. It will open from the shortcut but everything except the "monitor folder" is greyed out.

    On another note...tried my hand at nighttime shooting after the Germany-Turkey Soccer game tonight. Over two hundred shots and only 10 or so really came out decent! I have alot to learn.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts