I am a new member. Just joined just now but look forward to being part of the forums.

I got a Nikon D50 in Nov 06 and discovered after 2 months that the "Cha" message appeared and no photos could be taken. I took the camera back to the retailer who swapped over the memory card with another Jessops one.

This week - 2 months later again - the same thing has happened. I thought it meant the battery was not charged and charged it up fully.

This did not help. I took it back to the shop today and this time I have a Sandusk card and the minute I put it into the camera it worked.

Has anyone else experienced this problem? Is there anything else it could be?
I am mystified by this and because I am still getting to know the camera and really enjoy using it so I was reluctant to let it be sent away for repair as I honestly don't think it is the camera. Otherwise it would not have worked instantly when the new
card was inserted.

Your thoughts on this would be appreciated.

The forums look very interesting and I guess there's a lot of different levels of experience out there.

Thanks for any help.