Home News Buyers Guide About Advertising
Results 1 to 10 of 15

Hybrid View

  1. #1
    Join Date
    Aug 2006

    Memory Card Error - Card Locked


    I have a Canon PowerShot SD450 Digital Elph. I also have a 2GB memory card for the camera ('Secure Digital High Performance' and it also says foto source at the bottom of the label). On the weekend I took the card out because I forgot what brand it was. When I put the card back in I recieved the message "Memory Card Error" and "Card Locked" underneath it. Can't do anything on the camera. I've looked around on the internet and was told it's possible to recover the lost images before trying to format it to use the card again. I'm also using Windows 2000 Professional and a Core Micro USB card reader.

    When I use the card reader on my computer, it doesn't recognize the SD card that is in the reader. When I go to properties, it says 0 bytes. I thought I would try recovering anyways.

    I downloaded PhotoRescue software (trial version).

    First I tried selecting 'Logical Drive' for the options before trying to recover. It doesn't work, and asks for the drives information. So I entered 2GB as the card size, and 32k as the cluster size (looked it up on the internet). Once the program starts I just get all "READ ERROR AT..." errors followed by "The parameter is incorrect."

    Okay, so that method doesn't work.

    Next I try selecting the option of 'Physical Drive'... when I click the radio button for physical drive the program thinks for a moment then it displays "Drive 2 (1MB)" to select. Doesn't seem right, but I gave it a shot anyways. Again manually entered the memory card size and cluster size. After I start the recovery I of course get more errors. This time it's saying "READ ERROR AT..." followed by "The media on the drive may have changed" for a bunch of the first sectors that it scans. Then after the "READ ERROR AT..." it starts saying "The request could not be performed because of an I/O drive error". At least I think that's what it says, it cuts off after the word drive.

    When I tried both of these methods, during the scanning/recovery process it listed 1 drive found, and 0 files found the entire time. So this isn't looking good for my pictures that are on the card (probably around 100 on there).

    Does anyone have any other suggestions/solutions to recover the information? Or am I doing something wrong?

    Any help is GREATLY appreciated. Sorry for the long post but I figured with an issue like this it's good to have as much detail as possible.

    Thank you in advance for any insight into this issue.


  2. #2
    tniemotka Guest
    I know, I know, I know..... I am late, but I just saw this... And, if anyone else runs into this "Card Locked" error message on their digital camera..... this might help. I am sure ChrisH has already figured it out....

    If you take out the memory card and look at it... it has a little button on the side.... slide it over.... and then slap it back in the camera and that should take care of the problem.

    The chips have a little button on the side you can slide over and lock the chip so as to not accidently delete anything on the card... ChrisH must have accidently slide it over....


  3. #3
    Join Date
    Aug 2006
    No, that isn't the issue. That was the first thing to check for.

    Thanks anyways.

  4. #4
    Join Date
    Jul 2004
    Formerly South Wales. Now South Carolina.
    Try sliding the slider on the card both ways fully?

  5. #5
    Join Date
    Oct 2006
    Try upgrading your camera's firmware, as suggested by http://www.kingston.com/support/faqs/dmr/media7a.asp. I'm currently having the same problem with my Canon IXUS 55 and Kingston 1GB SD card, only (a) I don't have any pictures to worry about and (b) the card can still be read by my card reader and my PDA, only being "locked" when used in my IXUS. Good luck!

  6. #6
    bwanaman Guest

    One solution

    Okey, this can be tricky, but it worked for me.

    I have Canon Ixus 60 and Kingston SD 1gb memory card.
    After loading set of images on my laptop and putting the card back in to camera, screen displayed "Card Locked!" message.

    I did everything to check the common flaws, but still the same message occured.

    Material needed:
    1 paper clip

    The socket for memory card has this tiny detector for sensoring if the card is locked or not (same side as the lock switch on the MC). For some reason it was sticking out from the side. So, little fiddling with paper clip to put the detector back in and another try to put the camera on, everything worked out just fine.

  7. #7
    Join Date
    Nov 2006


    Did you find a solution to this problem?

  8. #8
    Join Date
    Jan 2008

    Other troubleshooting tips for this problem

    There are several additional troubleshooting items to check for the problems of "memory Card locked" or "memory card error". Not sure if they'll permit me to share this related link. But the link outlines the additional steps to take in a recommended progression to minimize risk of damage to the camera

    t00nz aka CR

  9. #9
    Join Date
    Dec 2010
    I had this problem with a Canon SD550 camera when I put a 4 GB card in it. Now I think I know the problem. The camera is not designed to handle a card larger than 2 GB. Larger than that and you get the error message.

  10. #10
    Join Date
    Jan 2011
    I have faced similar problem, in order to fix this error I formatted the memory card afterwards to restore the damaged photos I used macbook photo recovery application. It helped me to restore all the photos safely. You can try it !!!!!!!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts