Home News Buyers Guide About Advertising
Page 4 of 4 FirstFirst ... 234
Results 31 to 36 of 36
  1. #31
    Join Date
    Mar 2005
    Cambridge, UK
    I think Japan is metric and so I assume the ball bearing would be 2mm but do not suppose it would make that much difference.

    So I now have to choose if I want to spend $10 to play Dr Frankenstien and possibly get a working camera + a bunch of spare parts - OR - spend about the same amount and possibly get a working camera and have 49 left over bearing balls.
    Or have two cameras not working

    You have more confidence than me; I would not even attempt it in the first place.

    Note: Amazon sell them - 2mm Stainless ball bearings
    Last edited by Anthony; 08-26-2010 at 09:20 AM. Reason: Adde the note

  2. #32
    Join Date
    Nov 2009
    Quote Originally Posted by dnd4evr View Post

    Unfortunately there wasn't a warning about flying parts at this step (#28). The ball bearing went flying and I have no idea where it is. Unless someone knows what size the ball bearing is, I'm dead in the water. Does anybody out there have one they could check the size and let me know?
    I had the same problem with the (lack of warning) on step 28. Found the spring, but the bearing went somewhere ... somewhere else!
    Through trial and error I found a plastic bead that was just the right size.
    The camera worked, ... whell at list for a weak. Then the E18 returned.

  3. #33
    Join Date
    Nov 2012
    Hi All,

    I greatly appreciate if some one can help with the same kind of problem I have with Canon S2
    After lot of search I found this thread about the stuck lens problem on canon S2. I followed every step from1 to 33 and able to disassemble my camera. Now I have everything disassembled but I am not able to understand what is the problem? The gears look good.
    Just like everybody said I also got a spring and bearing. But in addition to that I got one more small part and I don't know what that is.
    Also I am not sure whether by problem go away if I assemble all of them. Do I have to look for anything else?

    Please help me

    Name:  DSC04515.JPG
Views: 1069
Size:  661.8 KBName:  DSC04516.JPG
Views: 1087
Size:  603.1 KBName:  DSC04517.JPG
Views: 1018
Size:  635.2 KBName:  DSC04518.JPG
Views: 1022
Size:  560.3 KBName:  DSC04519.JPG
Views: 1030
Size:  652.7 KBName:  DSC04520.JPG
Views: 1010
Size:  726.1 KBName:  DSC04521.JPG
Views: 1033
Size:  707.9 KB

  4. #34
    Join Date
    Dec 2012
    thank you very very much....
    To start the story......It was my friends engagement when my Canon S2 stucked with open lense.
    I tried all the tricks ...sometimes the lense could move in-out but suddenly stucked at extreme position with error E18.
    I tried to dissemble the camera but could not dare to open more than the bottom screws.I knew it was motor issue but same time I do not wanted to damage my S2.
    Next day I reached canon service center but returned back as I wanted to solve my problem by my own.I saw this post with amazing picture that gave me some hope.I purchased screw driver set and one nose plier.
    Before starting I planned to attack only motor portion and dissemled that part successfully and removed motor out of camera cavity.I found it was jammed so I tried with hand to make it move slightly.I found the motor was very hard to move but still After few minutes of excercise I re-installed the motor and started the camera.................and it worked.I donot need to proceed further as my problem was solved!!!!!!!

    Thank you very much for your support and great images.

  5. #35
    Join Date
    Jan 2013
    Can someone tell me, once you get down to the part where you are supposed to remove the outer lens barrel, how to do that? Mine would not come off. So I tried to go at things from the back side, removing those last 2 screws, and tried pulling it apart from that end. It is coming in pieces. But I think with the last photos posted above I could get it back together properly, if I could just get it fully APART first. I can't get the inner and outer lens barrels to turn against each other. It's like they are jammed. There was mention of a "lens lock" but no picture or description of what it was, or how to release it??? I can't see any way to go any further until I can get the lens barrels apart.

    The aperture hardware seems to be telescoped all the way forward as deep as it can go into the lens barrel assembly, and it won't come back toward the rear.

    Edit - OK, so after I tried and tried without success, I posted this, and decided to try 'one more time', and of course THEN it unscrewed! So now that I have it apart (my issue is that the aperture will not open to take a picture) and it appears there is not the slightest bit of grease or oil on the aperture pieces or mechanism, can anyone suggest what I might be able to do to make it work? From all appearances, it looks pristine. Unless the tiny motor device that works it has died or something.
    Last edited by Zoandar; 01-20-2013 at 02:29 PM.

  6. #36
    Join Date
    Feb 2013
    This discussion area are very much help me. I think helpful for every new member.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts