PDA

View Full Version : Lens problems



rock-iron
01-21-2009, 06:56 PM
Hi,

I have a Canon PowerShot S2 IS, I was taking pictures with it today, and I was using the zoom out and it is stuck out. When I turn it off and on, it still stays out and when I turn it back on, it is making noise like it is wanting to work, but then it turns off by itself and E18 comes on the LED screen. Does anybody have any ideas, Any help would be appreciated!

Thanks,

Zoinac
01-22-2009, 05:47 PM
Think it's due for a checkup with a canon repair tech.. I'm sure any local camera store will be able to help you out in that regard.

Mark_48
01-22-2009, 06:17 PM
If you haven't yet, try fresh or fully charged batteries. I've got an older Canon P&S that sort of did that if the batteries were weak. Other than that, maybe time for a trip to the Canon doctor.

jayfixit
01-23-2009, 08:12 AM
It's often a case of sand/dirt jamming up a gear.

David Metsky
01-23-2009, 09:29 AM
There's two other threads on this:
http://www.dcresource.com/forums/showthread.php?t=42865
http://www.dcresource.com/forums/showthread.php?t=42864

I guess this one has critical mass. :)

NWcityguy2
01-25-2009, 07:07 PM
I would not recommend mailing it in to Canon. They aren't going to quote you anything over the phone, and when they get it will probably give you the option between a $90 fix or the return shipping cost. I mailed in the A630 for some warrenty repairs and was told the same thing.

I'll second the recommendation to throw some fresh batteries in there and see if that helps. If that doesn't work you may find yourself in the market for a new P&S.