View Full Version : Olympus E500 arrow/directional key pad locked up?

02-17-2008, 05:00 AM
Have had no probs with this camera at all since purchasing it. Got it out last night to show a friend and when she'ld gone went to delete the shots she'd taken and instantly noticed the arrow keys weren't responding...

I've tried changing the battery in case it was just a low battery thing but no difference.

Have also tried removing and replacing the lens.

Am unable to try returning to factory settings as that requires the use of the arrow keys to access that part of the menu system!!!

Camera operates fine apart from this. I can focus and depress the shutter. Change shutter speed and aperture using the wheel on the top of the camera.

What I can't do is access any part of the main menu system or manually scroll through and delete photos in camera. I also seem to be unable to use the lock function ( AEL/AFL key symbol button ) on the viewable image during playback.

I'm stumped. Any ideas?

02-17-2008, 09:56 AM
Well, I have not had that happen on my E500 or E510 (or previous Oly's). You might try using the Olympus software to update the camera's firmware if you have an older version. Also, leaving the battery out overnight should drain the internal backup and effectively reset the camera.

I just took a look at my E510 menu and there is a setting for locking the arrow keys. The manual doesn't offer much detail. However, it seems that this should only affect the arrow keys as shortcuts to ISO, AF, etc.

02-17-2008, 12:26 PM
Thanks for the feeback.

Tried updating the firmware - hasn't made any difference.

Have removed the battery and will try again in the morning.

Failing that it will have to go back.

02-01-2013, 03:15 AM
I was with the exact same problem and I tried everything with no success. But by accident I fixed it when I pushed the PLAY button and started to review back/forth the images on the memory card. It's fine now and I hope this solution works again if needed.

Phill D
02-01-2013, 10:26 PM
Thanks for this info. Luckily it's never happened to me yet.
How on earth did you dig up this thread? but one day I might be glad you did.