View Full Version : EOS Digital Rebel DOA

Sean Pic-Kell
12-19-2004, 03:06 PM
I purchased a Digital Rebel as a Christmas Gift and tried to make sure it worked today. When I put in the charged battery it immediately asked me to set the time and date even though it was in the Off mode.

When I put in a CF card it came up with No CF card in the display. I have tried both a Lexar 64MB 8X and 128MB 12X card. The Format command returns the same No CF card message.

The On-Off switch doesn't appear to work either as the menu and display work whether in either mode and nothing turns on or off when I move the switch.

I have a message in to Canon but wondered if anyone else had a similar problem and if there is a reset that may make the camera work.



12-20-2004, 12:48 AM
Digital Rebels might not be all they are said to be...I owned a Canon D60, and have to say it was a completely trouble-free camera (and I even dropped it and it kept working fine). I was originally tempted to buy the Rebel because it had the same CMOS sensor, but was turned off by the plastic body of the Rebel because I wonder what else they cheaped out on. Call it paranoia, if you will! It could be that Canon made some other sacrifices we don't know about, and honestly they had to have, in order to make that camera so cheap. If you can, return that camera to the vendor ASAP if you have something like a 30 day money back guarantee. Then, try another if you want to, and see if the same problem crops up.

I also could not stand the 4 way buttons for working the menu on the Rebel. The D60 uses a wheel which is absolutely amazing at whipping through menus without any laborious repetitive clicking. The wheel, operated by your thumb, allowed me to make changes in ISO in mere seconds, and the way it interacted with the menu system was totally intuitive. You could also scroll through your shots in playback mode at lightning speed. I'm planning on buying the 20D because it has that wheel, besides a few other things!