View Full Version : E-300 died?

05-01-2007, 08:27 PM
I’ve been experiencing a camera malfunction lately (E-300), here is a brief description: As soon as my camera is turned on in either shooting modes – a picture is taken without any shutter press action.

The viewfinder remains black and I can’t access the menu panel or even view pictures on my card.

(If I use the “scenes” mode, I can select the preferred mode in the viewfinder no issues “viewfinder works”. Once I press ok to select the mode again a picture is taken automatically and the process mentioned above is the same…)

I tried other cards and lenses. Plugged the USB and updated my firmware to 1.4, still does it. Any tips?

05-02-2007, 06:35 AM
can you depress the shutter button, or does it feel trapped down ?
if it isnt something simple like that
Im afraid you are in for a visit to a camera tech

interestingly it sounds like the mirror is up too

05-05-2007, 10:33 AM
No shutter control at all. It takes a picture automaticaly once it's turned on.
i tried everything i could imagine... no luck even for viewing images on the cards.

The button seems functionnal, looks like the electronic chip took over
the camera controls... My olympus sales rep. said he's never seen this before. I will be waiting for approx. 1 month before getting a correct diagnosis. Will keep you posted...

05-05-2007, 10:37 AM
thanks, good luck with it