PDA

View Full Version : SanDisk Ultra II, 1GB OK on S2 IS, but unreadable on reader



Appia
10-04-2005, 03:15 PM
Thanks to the informative review of Canon Powershot S2 IS by Jeff Keller (http://www.dcresource.com/reviews/canon/powershot_s2-review), I just bought myself one Powershot S2 today.

I am still exploring the camera but am puzzled by a problem with my new SanDisk Ultra II 1 Gb card (faster than the normal type).

Photos can be recorded onto the card, displayed on the Canon Powershot S2 camera and transfered to the computer using Canon provided software, all without problem.

However, when I insert the Ultra II card into my card reader and try to see the photos on the card, the folder "DCIM" on the card refuses to open, with a message

"J:\DCIM not accessible. The file or directory may be unreadable or corrupt"

While at it, I tried and succeeded in creating a new folder on the card, meaning that the card is not locked.

I then used a noraml SD card, Transcend 1GB card (45X), to shoot a few photos using S2 camera. The folder DCIM\103Canon on the card can be opened on the card reader and all the photos can be viewed and copied without any problem.

I inserted the card Ultra II 1 GB into my Sanyo Xacti camera. An audio message showed up: Problem with memory card. The LCD display showed "Format, Full Format?"
After formating the SD card, Sanyo camera could take and display photos.

However, the same problem occurs when the Ultra II card is inserted back into the carder reader: the folder DCIM on the card can not be opened.

I even tried a different card reader and the problem is the same. What's wrong?

Is this the problem with the card or with the camera? :mad: Should I return the card for the full refund or exchange it with a new one?

Yoru advice will be appreciated.

Chucko
10-04-2005, 06:36 PM
That's the first time I've heard of any problems with a SanDisk memory card. But maybe I just don't get out much.

I had a similar problem on a TwinMos CF card - it wouldn't work on an older Lexar FireWire reader, but it works fine on a newer model Lexar reader. My cameras seem to like the card just fine.

My guess is card/reader incompatibility. Contact SanDisk and see if they have a firmware update available for your card, or if they'll let you exchange it. If you don't mind using the camera as a card reader, you could just grin and bear it.

Appia
10-05-2005, 01:28 PM
Thanks, Chucko, for the reply. Here is a followup:

I explained the problem to the shop assistant this afternoon. He used one of the demo notebook computers that had a SD card reader for testing the card. All the folders and photos on the Ultra II 1 GB card could be opened and viewed properly. One broken photo was found. His conclusion: the card was OK.

To play it safe, I asked for an exchange to which the shop assistant readily agreed without any hesitation.

Back home, I inserted the new card into a newer reader, Buffalo usb2.0 11-in-1 (bought at the begining of this year), and prayed. The photos that I had taken on the new card could be seen and opened for viewing without a problem, which delighted me.

I then inserted the same card into my old reader, Transcend 6-in-1 Reader (usb 1.0). To my dismay, the same error message that I had seen yesterday appeared: the folder corrupt or unreadable.

Conlusion: the SanDisk Ultra II 1GB card is not compatible with my Transcend 6-in-1 Reader (usb 1.0). . :eek:

Hope this info is useful to you guys.