Home News Buyers Guide About Advertising
 
 
 
   
Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2009
    Posts
    32

    Canon 100mm macro focus problem..??

    OK... I just bought myself a new Canon EF 100mm f/2.8L IS USM Macro Lens 2 weeks ago... razor-sharp closeups; no complaints there... but distant shots are not sharp... is there something obvious that I'm missing; or is this a defective lens..??... tried all various combo settings, manual/auto, etc... same results...any advice is appreciated..thx..Robert

  2. #2
    Join Date
    Aug 2007
    Location
    Brisbane, CA
    Posts
    3,591
    You mean you tried manual mode or manual focus? I'd try manual focus on a tripod. Seems like it should be sharp at all focusing distances. I've heard of something similar with the 35/1.4 L. I believe that person sent the lens into Canon to have it adjusted.
    Lukas

    Camera: Anonymous
    I could tell you but I wouldn't want you to get all pissy if it's the wrong brand

    Flickr

  3. #3
    Join Date
    Nov 2009
    Posts
    32
    Quote Originally Posted by TheWengler View Post
    You mean you tried manual mode or manual focus? I'd try manual focus on a tripod. Seems like it should be sharp at all focusing distances. I've heard of something similar with the 35/1.4 L. I believe that person sent the lens into Canon to have it adjusted.
    yup... I didn't even notice a problem for several weeks, as I was shooting macros... even distant shots @f/16 in sunlight are unsharp... I contacted my seller, Imaging World, & he said it sounded like a defective lens, & to return for replacement. I noticed there is currently a $120 factory rebate on this lens; I'm hoping they will re-issue my sales receipt, so I qualify for the rebate.

    thx for reply... Rob

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •