Home News Buyers Guide About Advertising
 
 
 
   
Results 1 to 9 of 9
  1. #1
    Join Date
    Sep 2008
    Posts
    2

    Kodak V570 service manual?

    I have a V570 that no longer opens the lens cover. The motor makes the attempt twice but then the camera shuts off. I've opened the front cover and there appears to be no problem with the sliding cover -- it appears to be the motor driving the lens cover. I'm hoping I can find a service manual somewhere before attempting further disassembly. Thanks in advance for any suggestions.

    --Steve

  2. #2
    Join Date
    Dec 2007
    Location
    Melbourne Australia
    Posts
    814

    Not lookin' good...

    I think - unfortunately - that "service manuals" for point 'n' shoot cameras are about as common as an ashtray on a Harley!

    I'm guessing it'll be a trip back to Kodak for service, but bear in mind that the repairs could cost more than the price of a similarly-equipped current model camera.

    The twin lens concept never really took off (think Ford Edsel), and anyway, many P&Ss now have 24mm or 27mm WA with comparable tele to the V570.

    Cheers

  3. #3
    Join Date
    Aug 2008
    Posts
    123
    Yes like most everything these days I'll guess it'll be cheaper to buy new rather then to repair.
    sw2cam

  4. #4
    Join Date
    Dec 2007
    Location
    Melbourne Australia
    Posts
    814

    Cheap(ish) new toy?

    Steve...

    You could get something like this Fuji FinePix J150w for less than $200.

    It's got a 3.3-5.1, 5X optical zoom lens, equivalent to 28mm wide - 140mm tele, and a very nice 3" LCD with 230,000 pixels.

    Cheers

  5. #5
    Join Date
    Aug 2008
    Posts
    123
    LOL .... people are always pushing something when they don't have an answer to the question.

    You could always get a
    KODAK
    Z885
    Z1285
    Z8612
    V803
    V1233
    V1073
    V1003

    For under $200 bucks U.S. not to mention 17 other KODAK rigs that are under $200.00.
    Then if you would like to you could always bid on a KODAK factory refurbed rig at http://stores.ebay.com/Kodak-Outlet. I've bought many cameras, printers, and printer docks from that location. Last camera was a Z712is for $117 and change ..... seeing this is a KODAK board of this forum I'll not hawk other brands here. Like them or not.
    sw2cam

  6. #6
    Join Date
    Sep 2008
    Posts
    1
    Hi Steve,
    I also have a V570 that is acting just like yours! I thought the lens cover was opening when it first started powering down after a flew light flashes and the Kodak Easy Share screen coming up but I may have been mistaken because it is not opening now.
    I went to Kodak's on line help desk, followed their instructions, and was told to send it in for repair (for over $150!!! - I don't think so). Took it apart like you - found nothing - put it back together and NG. Thought it might be the battery or memory card but then thought of a forum. What happens if you hold the lens cover open?
    Larry

  7. #7
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Posts
    4,428
    I doubt there is any camera service manual that tells you how to fix such faults.
    Nikon D90, D80
    Nikkor 16-85mm AF-S DX F/3.5-5.6G ED VR, Tamron SP AF 28-75mm F/2.8 XR Di LD Aspherical (IF) macro, Nikkor 50mm F/1.4D, Nikkor 50mm F/1.8D, Nikkor AF-S VR 70-300mm F/4.5-5.6G IF-ED, Sigma 105mm F/2.8 EX DG Macro ||| 2x SB800 | SB600 ||| Manfrotto 190XB

  8. #8
    Join Date
    May 2008
    Location
    Gold Coast, Australia
    Posts
    15
    Kodak authorized servicers would have been given repair information.

  9. #9
    Join Date
    Sep 2008
    Posts
    2
    Comdivers--

    In my case the problem is not the lens cover. It appears that the motor is jammed. It might be possible to fool the camera into going further but I was hoping to clear whatever is jamming the motor (grit?).

    I had removed the front cover, but didn't want to do further disassembly without some idea of what to be aware of. Last time I took apart a microcassette recorder (for a trivial switch problem) I never managed to get it back together...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •