Home News Buyers Guide About Advertising
 
 
 
   
Results 1 to 7 of 7
  1. #1
    Join Date
    Dec 2006
    Posts
    4

    need help: my sony camera says "format error"

    whenever i open my sony camera, the lcd is pure blue with a text saying "format error"(w/c is blinking) and the icon for memory space is also blinking. i don't know how did it happened, but can i just tell you what are things that i've done to my camera...

    first i took a photo, and transfer it to my pc with a usb cable, and when trying to view the photo(i took a while ago) using my pc,it can't be viewed, even in a thumbnail view. and then i accidentally turn off the camera while it is connected to the computer, which i think that root of the problem. and then i took another photo, but when viewing it using the digital camera, it's with a smaller pixel(which is unusual thing for me).and then suddenly the lcd turned to blue saying "format error", and i cannot view other photos and take photos. i turn it off saying that it is just a temporary error. and turn it on again and it works, i took another photo, and when i view it using the camera, the photo looks distorted(please see the attachment), and suddenly the lcd again turned to blue (format error). realizing that the icon for memory space is also blinking, i thought that the problem would be on the memory, so i pulled out the memory stick pro duo, and turn the camera on. and it works. but when i placed the sony memory stick PD, it always says "format error". so i think the problem would be on the memory stick. but when i plugged my camera(with memory stick) to my pc, there's no problem, i can view the other images but the latest photos can not be viewed, sometimes it says "drawing failed", and the others are distorted just like the picture on the attachment...

    my problem now is that i can't use my sony memory stick pro duo, which i really need tomorrow, is there anyway to fix the problem? or its time to buy another one? i wish you could help me guys... thanks
    Attached Images Attached Images  

  2. #2
    Join Date
    Dec 2006
    Posts
    4
    guys, could you please help me solve my problem? the "format error" problem is now solved, i just formatted the MSPD, but whenever i took photos, the pictures, are still distorted just like what i've attached on my first post...

  3. #3
    Join Date
    Oct 2005
    Posts
    18
    Hi.

    I may be able to help, but you need to tell me what model of Cyber-shot you have?

  4. #4
    Join Date
    Dec 2006
    Posts
    4
    DSC-S600
    mpegmovieVX
    Cybershot-shot 6.0 megapixels

    thanks v8griff

  5. #5
    Join Date
    Oct 2005
    Posts
    18
    Looks like your camera may have a faulty CCD unit. Unfortunately the S600 is not one of the models entitled to a free repair.

  6. #6
    Join Date
    Dec 2006
    Posts
    4
    sorry but i don't understand what CCD unit is... so do you mean there is something wrong with my camera? hardware problem? not in my memory stick? sounds confusing... because whenever there is no memory stick inserted, and when i took photos, the pictures are clear and not distorted...

  7. #7
    Join Date
    Jan 2007
    Location
    Mipple City
    Posts
    3

    CCD = Charge-Coupled Device

    It's what the light hits when the shutter opens. It's what makes a digital camera work. Without it, you have a paperweight.

    Ask how much it'll cost to repair it, but you'll likely have to replace the camera. (it looks like the same model is running about $140 or even less on eBay)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •