Home News Buyers Guide About Advertising
 
 
 
   
Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 43
  1. #11
    capted Guest

    Olympus stylus 400

    My camera started the same scenario. Lens retracts a few seconds after cover is opened. Thanks to this forum, I discovered it is something in the sliding lens cover.
    If I put pressure on it, the camera will stay on. It has been on over half an hour now since I read this forum.

  2. #12
    Beedee Guest

    C-50 has same problem

    I had my Olympus C-50 not even for 3 years now and experience the same problem - the pin inside the sliding door pops out because a part of the plastic that guides it cracked.

    I called Olympus and they say it will be about $125 to repair.
    You can also order repalcement parts from their website, but not the one I need.
    Pretty disappointing. I could get a new C-50 on ebay for half of the repair cost - but it would be nonsense to buy the same model again, knowing its flaws.

    I'll try to repair it with one of your suggestions - beer can and superglue...

  3. #13
    maceo Guest

    Olympus 410 - no problems so far...

    Just had the flash go out though. never had that happen before. This has been an awesome camera, my second olympus. It is heavily used, 5000+ pictures, and hopefully I will have a pleasurable repair experience. I also have a Fuji S2 Pro SLR in for repair, so this SUCKS... need a third back up I guess. Geez, when it rains, it pours...
    Highly recommended... when it works. Like I said this has been my only issue come up. It still works great with available light, just no fill flash for indoors at the moment. I am online to find out wheere to send it to get the internal flash replaced.

  4. #14
    Join Date
    May 2006
    Posts
    2

    Angry Olympus Stylus 400 Camera Problem

    Yes, I have the same problem as does my son with his camera. I have talked with Olympus and they sure knew about my problem when I called them about it to see if there was a recall on this Stylus 400 shutter problem. The solution they offer is to send them the camera and expect a repair bill of $119.00. Or they have an upgrade program where they would take your camera, offer you a trade up, for instance, a Stylus 600 which they sell for $299, they will sell it to you for $240. Big deal!!!!

    I think we are being taken advantage of and I am considering keeping this Olympus as a reminder and buying another brand and chalking this up to a bum deal.

  5. #15
    Join Date
    May 2006
    Location
    New Jersey
    Posts
    1,651
    My first two digital cameras were by Olympus (D460Z and Stylus300). Both have the slider lens cover. I bought the D460Z back in 2000, and it's still in great working condition (but I don't use it anymore). I bought the Stylus 300 in 2003, and it's still in great working condition and I still use it along with my Canon S3.

    Believe me when I say that my old cameras have gone through some abuse Olympus makes good cameras. So I'm not sure if the defects are isolated to certain models.

  6. #16
    betracq Guest

    Cool Olympus mju 300/400 defect

    I read with interest the posts on this topic. There is absolutely no doubt that there is a defect with the on/off mechanism operated by the sliding cover. Occasionally this can be fixed by adjustments to the cover, but more usually the problem lies with a tiny switch inside the camera. I have now seen many of these where the (minute) operating lever for this switch has broken, and of course no amount of adjustment of the cover will fix that. It is necessary to dismantle the camera, and in a few cases I have managed to lash up a temporary fix with a bit of copper strip soldered to the circuit board. If you open up the camera be very careful to avoid touching the contacts of the capacitor which drives the flash unit; it holds its charge well, at around 300 volts, for several days and can give you quite a shock. I speak from personal experience!

    I feel sure Olympus are very well aware of this problem; I have never contacted them since I feel it would be pointless, although if anyone out there can be bothered the threat of a law suit might wake them up. If you look on E-bay you'll see no end of these cameras with a similar fault.

  7. #17
    brycen Guest

    Unhappy Me too

    Chalk up another three. Two with my bother, and my camera followed halfway during an overseas vacation. The cover was *always* finicky... closing unintentionally half the time. But now I have a perfectly good Stylus Zoom 300 camera, with no way to turn it on. !@#!@#!# defect.

    I took the cover off, and the little black plastic switch does nothing.

  8. #18
    camera mom Guest

    Olympus sliding front got us too!


    ME TOO!
    Also having the problem with our olympus stylus 300- it won't open and start. It has already been repaired once by the company-
    luckily paid by my visa charge company- as it elongated my guarantee. You may try that for a few more months of working.
    Now it is not working again! So by searching here and other places i thought i'd try taking the front apart. We are also very disappointed in the Olypmus name and they still used that mechanism for years!
    This was a gift for my daughter's graduation and she is not even using it.

    I finally took the slider part off and turned the little black plastic circular thing with the point sticling up - and by taking the battery out and then inserting it- the camera will turn on and take pictures... have to take the battery out to stop the camera. THEN put the battery back in again and when the camera restarts close the cover on the lense thing and hold it down until it turns itself off-
    - but i think i will try to just leave off that sliding cover and operate the camera by taking the battery in and out. Then i will have to leave the lense sticking out open - but-- that's the best so far.

    The moving the lens of the camera did seem to work but when i put the slider back on- still didn't operate by itself.

  9. #19
    mjg Guest

    olmypus 400 switch repair

    I have dismantled my Olympus 400 to find out why my lense would not open.
    I found a small piece of black plastic in the case that may have broken of the rotory switch actuator or the switch itself. Does anyone have a diagram, sketch, or picture of what these parts should look like? Thanks in advance
    mjg

  10. #20
    Join Date
    Jul 2006
    Posts
    2

    Exclamation Olympus MJU 300 not starting

    I have a problem with my camera too.

    When I slide the lens cover across:

    - Lens pops out (like normal),
    - Screen comes up with 'Olympus' (like normal),

    but then ...

    - The screen goes black,
    - The lens goes back inside,
    - and the Green Lamp flashes and beeps about 9 times.

    Sinse then it has worked normally. I have tried charging the battery and putting pressure on the lens cover, but nopthing works! The only thing I can do with the camera now is view the pictures (not that there's any on there because I've copied and deleted them).

    I can't dismantle the lens cover (because I don't have a screwdriver of that small size) and I can't just go to a repair shop (1 because I'm only 14 and 2 I haven't told my parents yet). The camera is about 2-ish years old (I think) and it just stopped working one day. (It was in my bag, I got it out and it didn't work. Probably because it had been knocked around? IDK )

    I need help urgently! Please!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •