Home News Buyers Guide About Advertising
 
 
 
   
Results 1 to 2 of 2

Hybrid View

  1. #1
    gohnsman Guest

    Unhappy Fuji S5000 power unit problems

    I sent in my Fuji S5000 for repairs after the electonics ceased functioning after plugging in the USB cable to download to my computer. I heard a "pop" and smelled a lovely hot odor. Now the authorized Fuji repair service tells me the whole power unit needs to be replaced; the housing may need to be replaced, possibly another "board", so they suggest sending it back to the factory. The camera never got wet, wasn't dropped, no possible cause. Out of the 1 yr. warranty by only 4 months. Has anyone else had problems like this? Should I go head to head with Fuji? The repair may be almost as expensive as buying a new camera. Thanks for your thoughts.

  2. #2
    Join Date
    Aug 2005
    Posts
    18

    Post

    I would think that they would warrantee that repair. It seems to me they put something together wrong. Seems too strange a coincidence that it worked fine before, the power part that is, and as soon as they put in a new board, it blows.

    I would push them to fix it under warrantee. Talk to Fuji on it also.If not, get a new one. But keep it for parts. I read a lot of people looking for spare parts on these Fuji forums. Things like knobs, etc..

    I had a 5000 and we turned in because it had a single dead pixel, but I miss it. We replaced it with a 5100, and there are a couple of things the 5000 did better.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •