PDA

View Full Version : Problem with A70



dbf
09-06-2004, 01:22 PM
I purchased an A70 back in May 2003. This past week, while taking some pictures, the LCD just showed back. Pictures taken a few minutes prior had not problems.

At this point, I am able to review pictures already on the CF card and I am able to see and adjust settings, but when trying to take new pictures, I do not see an image. When I hold the camera up to a bright light, the screen does lighten up and I do see some traces of color, but that is about it. Since I am out of warrenty, I am not planning on getting the camera repaired, but before I go out a buy a new one (I am looking at the S1 IS and Fuji S5000), I want to be sure this is not a "Typical" Canon problem.

This happened to me this past Thurs. I spoke to a co-worker and his A70, which he purchased based on my recommendation also had the same malfunction about 3 weeks ago.

Is this a known issue with Canon?

D70FAN
09-06-2004, 05:24 PM
I purchased an A70 back in May 2003. This past week, while taking some pictures, the LCD just showed back. Pictures taken a few minutes prior had not problems.

At this point, I am able to review pictures already on the CF card and I am able to see and adjust settings, but when trying to take new pictures, I do not see an image. When I hold the camera up to a bright light, the screen does lighten up and I do see some traces of color, but that is about it. Since I am out of warrenty, I am not planning on getting the camera repaired, but before I go out a buy a new one (I am looking at the S1 IS and Fuji S5000), I want to be sure this is not a "Typical" Canon problem.

This happened to me this past Thurs. I spoke to a co-worker and his A70, which he purchased based on my recommendation also had the same malfunction about 3 weeks ago.

Is this a known issue with Canon?

Not a problem reported before, but try leaving the batteries out for 24 hours to "reset" the camera. If that doesn't work then you may have a problem so contact Canon.

Melissa
11-17-2004, 06:02 PM
You probably have already bought a new camera but I thought you might be interested to know that I also had problems with my A70. Only 2 weeks after buying it the shutter wouldn't close properly. Canon 'repaired' it but the same problem occurred 8 months later. I have written a few letters to canon and complained and am getting a refund.