PDA

View Full Version : Sensor degrade ?



adventurer
03-19-2005, 10:43 PM
Hi,
I have an Olympus digital camera for almost 2 yrs already. Recently it seems from the pictures taken, the color has been more dull compared to when i bought the camera. Someone suggest that it could be due to sensor degrade. I'm wondering how true is that. Has anyone seen this happen before ?
Regards.

palmbook
03-19-2005, 11:09 PM
Yes, the sensor degrades itself from time over time. This corrosion occurs faster if you usually use high ISO setting.

gary_hendricks
03-20-2005, 05:49 AM
Which Olympus model are you using?

adventurer
03-20-2005, 07:27 AM
I have a C-750UZ.

Most of the time i would be using either ISO100 or 200 at most. I think i must have taken thousands of photos using this camera.

But still, 2 yrs is quite short...

Norm in Fujino
03-20-2005, 08:58 AM
I have a C-750UZ.
Most of the time i would be using either ISO100 or 200 at most. I think i must have taken thousands of photos using this camera.
But still, 2 yrs is quite short...

Is there some documented source of info for this issue of sensor degradation?

palmbook
03-20-2005, 12:28 PM
Is there some documented source of info for this issue of sensor degradation?
I have, but it's not in English :(

Norm in Fujino
03-20-2005, 04:14 PM
I have, but it's not in English :(

Japanese is okay, too. :)

jkusmier
04-18-2005, 01:15 PM
Yes, the sensor degrades itself from time over time. This corrosion occurs faster if you usually use high ISO setting.

Don't mean to sound like a jerk, but I've ever heard that one before. And higher ISO settings have no impact on the imaging sensor, since changing ISO doesn't actually increase or decrease sensitivity, but merely instructs the camera to boost the signal generated by the sensor when processing the image.

Try restoring factory default settings and then tweaking from there. If anything, I suspect that your LCD monitor has become a bit duller w/ age.