PDA

View Full Version : Exilim-s500 PROBLEM!!



jgoods
03-27-2006, 05:11 AM
I just recently bought an s500 a month ago in the states. I am currently in australia and had a friend mail the camera to me a couple weeks ago. 3 days later it stopped working. I'm fuming. When i turn it on, the lens opens and extends. then it makes about 10 clicking noises and the screen goes black. The camera works (in that i can see an image through the lens) for a second when the lens first extends. The only way to retract the lens is to put it into "view" mode (so the lens retracts). any help is soooo appreciated, as i am on vacation here and cannot use my brand new camera. Also, I have the older 2mp version of the exilim slim and the flash stopped working the day after the s-500's problems. any recommendations for that issue? quite frustrating. :mad:
Thanks very much,
Jared

fafi
04-12-2007, 06:51 PM
I recommend you to contact TIM CASON. Just google him, he does repairs for casio cameras.

I own the White Casio S-500 and the first time I got my camera repaired was because I dropped my camera and the silver ring around the exterior of the lens popped off, the lens was damaged and did not extend/retract. And then worst comes to worst the battery stopper breaks off in my attempt to take out the battery.

The second time I had to send it out was because of problems with the LCD screen. When I turned on my camera there were many white lines that appeared on the screen. In addition, my battery clip broke off again.

To be honest, at first I was skeptical on mailing out my camera and getting it repaired by Tim. So I checked out his site and contacted him through e-mail. The repairs for all the problems I experienced were for a fair price and I got my camera in a few weeks. And you get a 6 month repair warranty.