PDA

View Full Version : Olympus C-750 defective EVF and LCD



Russo69
07-18-2005, 09:03 AM
Can anyone help?


I own a C-750 UZ for more than a year now...an all of the sudden my EVF and LCD are all red... :confused: it's like if it was the only color they can handle... :( even the Olympus welcome screen is red... :eek: The pictures taken are still fine...but I can hardly see anything through the EVF nor LCD it's all red... :mad:

Is there a setting that could be causing it?

Is the camera defective?

SamPhilly
07-18-2005, 09:26 AM
I have a 770, only for a few months. I never saw an option to change the LCD color. If the photos are good then I would say the LCD is bad.

Russo69
07-18-2005, 09:33 AM
yeah...I have a feeling they are defective...I was kinda of intrigue about it...how can the EVF and the LCD monitor have the same problem...I guess they must be sharing the same defective device... :confused:

???

albundyhere
10-29-2005, 09:56 AM
Can anyone help?


I own a C-750 UZ for more than a year now...an all of the sudden my EVF and LCD are all red... :confused: it's like if it was the only color they can handle... :( even the Olympus welcome screen is red... :eek: The pictures taken are still fine...but I can hardly see anything through the EVF nor LCD it's all red... :mad:

Is there a setting that could be causing it?

Is the camera defective?


Didnt I see your auction on ebay recently? LOL!

Geoff Chandler
10-30-2005, 12:20 PM
I have a feeling the colour on the screens can be changed - but not to that degree - can you see the omage at all? I reckon it's a repair job - or else
it's put up or change - shame though - good little camera.

Norm in Fujino
11-01-2005, 04:12 AM
LATER edit:
Oops, since both LCD and EVF are going red, it sounds like some internal circuitry has gone haywire. It might or might not be an easy fix, so I'd at least send it in to service and get a quote for repairs.